Compiling the sources

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 05:00, 13 June 2005 (edit)
Dpatton (Talk | contribs)
(Get the Source Code)
← Previous diff
Current revision (10:58, 30 January 2018) (edit) (undo)
Bull (Talk | contribs)
m (Reverted edits by Monday (Talk); changed back to last version by Mkpl)
 
(22 intermediate revisions not shown.)
Line 1: Line 1:
-'''Compiling the sources''' allows you to create executables from modified code. The instructions below show you how to compile the lastest code from the CVS repositories.+'''Compiling the sources''' allows you to create executables from modified code. The instructions below show you how to compile the lastest code from the SVN repositories.
==Preparation== ==Preparation==
Line 6: Line 6:
The following software must be installed before starting. The following software must be installed before starting.
See [[Development Tools]] for download locations. See [[Development Tools]] for download locations.
-*.NET Framework SDK+*.NET Framework SDK 2.0 ([http://www.microsoft.com/downloads/details.aspx?familyid=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en NET Framework 2.0 Software Development Kit (SDK) (x86)])
-*DirectX SDK+:Note: If you have already installed Microsoft Visual Studio .NET 2005, you do not need to install the .NET Framework SDK separately. Visual Studio .NET 2005 includes the SDK.
-*A CVS client (e.g. TortoiseCVS or WinCVS)+*Managed DirectX ([http://www.microsoft.com/downloads/details.aspx?FamilyID=4B1F5D0C-5E44-4864-93CD-464EF59DA050&displaylang=en DirectX 9.0c Redistributable (February 2007)])
-*A C# compiler (e.g. Visual Studio or NAnt)+:Note: Above is the latest version. World Wind should compile with [http://www.microsoft.com/downloads/details.aspx?FamilyID=9930efa6-9f7b-4c8a-aea2-97dd6ab307a2&DisplayLang=en October 2005 version]
 +*A SVN client (e.g. [http://tortoisesvn.tigris.org/ TortoiseSVN])
 +*Visual Studio 2005 (free Visual C# Express version available from [http://msdn.microsoft.com/vstudio/express/visualcsharp/default.aspx Microsoft])
===Get the Source Code=== ===Get the Source Code===
-See [[Source Code]] for more information.+See [[source code]] for more information.
-====Using TortoiseCVS====+====Using TortoiseSVN====
#Create a directory on your drive where you'd like to develop from (eg C:\wwdev) #Create a directory on your drive where you'd like to develop from (eg C:\wwdev)
-#Right-click in that directory and select "CVS Checkout"+#Right-click in that directory and select "SVN Checkout"
-##On the Module tab:+##Repository:
-###CVSROOT = :pserver:anonymous@cvs.sourceforge.net:/cvsroot/nasa-exp+###URL of repository = https://nasa-exp.svn.sourceforge.net/svnroot/nasa-exp/trunk/WorldWind
-###Server = cvs.sourceforge.net+##Revision: if you want to use anything other than SVN HEAD revision, you'll have to select "Revision" radio button, then click the "Show log" button, then select the revision from the list
-###Repository folder = /cvsroot/nasa-exp+
-###User name = anonymous+
-###Module = WorldWind+
-##On the Revision tab, if you want to use anything other than CVS HEAD, you'll have to select "Choose branch or tag", then click the "Update list" button, then select the branch/tag from the list+
-##On the Options tab, you may want to change "Name of folder to create" to use the tag/branch/revision in the folder name+
##Click OK, and the source code should be downloaded ##Click OK, and the source code should be downloaded
-##Click OK to close the TortoiseCVS window+##Click OK to close the TortoiseSVN window
-====Using WinCVS====+
-#Create a directory on your drive where you'd like to develop from (eg C:\wwdev)+
-#Launch WinCVS+
-#Select your directory in the directory pane on the left side+
-#Right Click and choose "<code>Checkout Module...</code>"+
-#Type "<code>WorldWind</code>" in "Module Name and path on the server"+
-#Type "<code>:pserver;username=anonymous;hostname=cvs.sourceforge.net:/cvsroot/nasa-exp</code>" in "CVSROOT"+
-#Click OK. CVS Will now check out the source code for WorldWind in a "<code>WorldWind</code>" directory under your chosen one. (A window may come up asking for your default directory. Just click OK)+
-#Close WinCVS+
-===Copy Data===+==Compile the Source Code==
-Now copy the "<code>C:\Program Files\NASA\World Wind 1.3\Data\Earth</code>" directory to "<code>C:\wwdev\WorldWind\bin\Debug\Data</code>"+
-==Compile the Code==+===Compiling using Visual Studio===
-===Compiling with NAnt===+====Compile within Visual C# Express====
-#Open a Command Prompt and cd to your work directory (<code>cd \wwdev\WorldWind</code>)+Replace C:\wwdev\ with your source directory:
-#<span>Type "<code>c:\nant-0.85-rc2\bin\nant</code>" (change the path to reflect where you installed Nant)<br>or "<code>c:\nant-0.85-rc2\bin\nant -buildfile:default.release.build</code>" for non-debug binaries</span>+#Navigate to the following file and double click it:
-If all goes well, you should get <tt>BUILD SUCCEEDED</tt> in the end+##C:\wwdev\WorldWind\WorldWindow.csproj
- +##or C:\wwdev\WorldWind.sln
-===Compiling with Visual Studio===+#From the Build menu, select Build Solution, and in the Output window you should get a message that the build succeeded.
- +#Close Visual Studio
-====Compile within Studio====+:You may choose 'Debug' or 'Release' from the Build->Configuration Manager menu.
-#Navigate to the following file (double click it):+=====Importing into Visual C# 2008 Express=====
-##C:\app\ww\src-cvs\WorldWind\WorldWindow.sln+#Click ''File->Open Project''
-##If using MS VS 2005 it will ask to convert the file, NEXT->NEXT->FINISH+#Navigate to the source directory
-##F6 to build+#Choose ''WorldWind.sln'' and click ''Open''
-##Close MS VS+#In the Conversion Wizard click ''Next''
-#Navigate to the following file (double click it):+##You can create a backup before converting the project.
-##C:\app\ww\src-cvs\WorldWind\WorldWind.sln+#Click ''Next'' again, review the summary and click ''Finish''
-##If using MS VS 2005 it will ask to convert the file, NEXT->NEXT->FINISH+##Here you can review coversion errors - just ignore them, WW should compile fine.
-##F5 to build and start+#Click ''Close''... Voilà! You can compile WW now. Make sure to choose 'Debug' or 'Release' from the Build->Configuration Manager menu as some of the other configurations will give errors.
-<!-- Safe to remove?+
-##You may now get an error due to a missing file +
-###Could not find a part of the path C:\app\ww\src-cvs\WorldWind\bin\Debug\Data\Earth\Placenmaes\Country\ww.wpl+
-###Copy the (Earth) folder from the 1.3 install of the full application directory start from C:\Program Files\NASA\World Wind 1.3\Data TO C:\app\ww\src-cvs\WorldWind\bin\Debug\Data+
-##Now retry step 5.3, it should launch+
--->+
-##Final step MSVS->Main Menu->File->Save or Save as.+
====Compile from the commandline==== ====Compile from the commandline====
-# Launch the 'Visual Studio .NET 2003 Command Prompt' (under Start / Programs / Visual Studio .NET / Visual Studio .NET Tools)+# Launch the 'Visual Studio .NET 2005 Command Prompt' (under Start / Programs / Visual Studio .NET / Visual Studio .NET Tools)
# CD to the WorldWind source root. # CD to the WorldWind source root.
# Run 'Devenv.exe WorldWindow.sln /build Debug' # Run 'Devenv.exe WorldWindow.sln /build Debug'
# Run 'Devenv.exe WorldWind.sln /build Debug' # Run 'Devenv.exe WorldWind.sln /build Debug'
-* Replace 'Debug' with 'Release' as desired+:Replace 'Debug' with 'Release' as desired
-* As of 1.3.0 the references in the Release build point to /Debug dll's. So to /rebuild a release, /rebuild debug first.+:As of 1.3.0 the references in the Release build point to /Debug dll's. So to /rebuild a release, /rebuild debug first.
 +==Data Setup==
 +Select one of the following options:
 +#Use a fresh copy of imagery and terrain data - just proceed to the next section to run the compiled code
 +#If you already have a version of World Wind installed, and you already have files on your PC's harddisk that you want to make use of:
 +##Cache files - use either of the following:
 +###Copy your existing Cache directory (e.g. C:\Program FIles\NASA\World Wind\Cache) to be a subdirectory of the directory containing your compiled source code's executable file (e.g. C:\wwdev\bin\debug\Cache)
 +###If you already have a version of World Wind installed, and you already have files cached on your PC's harddisk that you want to make use of, then you can change your compiled version of World Wind to point to that existing directory. Run World Wind, press Alt+Q, then change the Cache path to point to your exisiting Cache directory, close the window, then restart World Wind.
 +==Run Your Compiled Code==
 +Your newly built World Wind should now be ready to go. Double click on WorldWind.exe (e.g. C:\wwdev\bin\Debug\WorldWind.exe) and it should start.
-==Run Your Compiled Code==+If you make changes to the source files that you would like to compile, just follow the [[#Compile the Code|Compile the Code]] instructions again to recompile, and after the compile, make sure to save the changes.
-Your newly built WorldWind should now be ready to go. Double click on "<code>WorldWind.exe</code>" in "<code>C:\wwdev\WorldWind\bin\Debug</code>"+
-and it should start.+
-If you make changes to the source files that you would like to compile, just follow the [[#Compile the Code|Compile the Code]] instructions again to recompile.+==See also==
 +*[[Latest builds]] to get already compiled builds
[[Category:Dev]] [[Category:Dev]]

Current revision

Compiling the sources allows you to create executables from modified code. The instructions below show you how to compile the lastest code from the SVN repositories.

Contents

[edit] Preparation

[edit] Install Software

The following software must be installed before starting. See Development Tools for download locations.

Note: If you have already installed Microsoft Visual Studio .NET 2005, you do not need to install the .NET Framework SDK separately. Visual Studio .NET 2005 includes the SDK.
Note: Above is the latest version. World Wind should compile with October 2005 version
  • A SVN client (e.g. TortoiseSVN)
  • Visual Studio 2005 (free Visual C# Express version available from Microsoft)

[edit] Get the Source Code

See source code for more information.

[edit] Using TortoiseSVN

  1. Create a directory on your drive where you'd like to develop from (eg C:\wwdev)
  2. Right-click in that directory and select "SVN Checkout"
    1. Repository:
      1. URL of repository = https://nasa-exp.svn.sourceforge.net/svnroot/nasa-exp/trunk/WorldWind
    2. Revision: if you want to use anything other than SVN HEAD revision, you'll have to select "Revision" radio button, then click the "Show log" button, then select the revision from the list
    3. Click OK, and the source code should be downloaded
    4. Click OK to close the TortoiseSVN window

[edit] Compile the Source Code

[edit] Compiling using Visual Studio

[edit] Compile within Visual C# Express

Replace C:\wwdev\ with your source directory:

  1. Navigate to the following file and double click it:
    1. C:\wwdev\WorldWind\WorldWindow.csproj
    2. or C:\wwdev\WorldWind.sln
  2. From the Build menu, select Build Solution, and in the Output window you should get a message that the build succeeded.
  3. Close Visual Studio
You may choose 'Debug' or 'Release' from the Build->Configuration Manager menu.
[edit] Importing into Visual C# 2008 Express
  1. Click File->Open Project
  2. Navigate to the source directory
  3. Choose WorldWind.sln and click Open
  4. In the Conversion Wizard click Next
    1. You can create a backup before converting the project.
  5. Click Next again, review the summary and click Finish
    1. Here you can review coversion errors - just ignore them, WW should compile fine.
  6. Click Close... Voilà! You can compile WW now. Make sure to choose 'Debug' or 'Release' from the Build->Configuration Manager menu as some of the other configurations will give errors.

[edit] Compile from the commandline

  1. Launch the 'Visual Studio .NET 2005 Command Prompt' (under Start / Programs / Visual Studio .NET / Visual Studio .NET Tools)
  2. CD to the WorldWind source root.
  3. Run 'Devenv.exe WorldWindow.sln /build Debug'
  4. Run 'Devenv.exe WorldWind.sln /build Debug'
Replace 'Debug' with 'Release' as desired
As of 1.3.0 the references in the Release build point to /Debug dll's. So to /rebuild a release, /rebuild debug first.

[edit] Data Setup

Select one of the following options:

  1. Use a fresh copy of imagery and terrain data - just proceed to the next section to run the compiled code
  2. If you already have a version of World Wind installed, and you already have files on your PC's harddisk that you want to make use of:
    1. Cache files - use either of the following:
      1. Copy your existing Cache directory (e.g. C:\Program FIles\NASA\World Wind\Cache) to be a subdirectory of the directory containing your compiled source code's executable file (e.g. C:\wwdev\bin\debug\Cache)
      2. If you already have a version of World Wind installed, and you already have files cached on your PC's harddisk that you want to make use of, then you can change your compiled version of World Wind to point to that existing directory. Run World Wind, press Alt+Q, then change the Cache path to point to your exisiting Cache directory, close the window, then restart World Wind.

[edit] Run Your Compiled Code

Your newly built World Wind should now be ready to go. Double click on WorldWind.exe (e.g. C:\wwdev\bin\Debug\WorldWind.exe) and it should start.

If you make changes to the source files that you would like to compile, just follow the Compile the Code instructions again to recompile, and after the compile, make sure to save the changes.

[edit] See also

Personal tools