Compiling the sources

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 06:56, 13 June 2005 (edit)
24.23.82.233 (Talk)
(Install Software)
← Previous diff
Current revision (10:58, 30 January 2018) (edit) (undo)
Bull (Talk | contribs)
m (Reverted edits by Monday (Talk); changed back to last version by Mkpl)
 
(20 intermediate revisions not shown.)
Line 1: Line 1:
-'''Compiling the sources''' allows you to create executables from modified code. The instructions below show you how to compile the lastest code from the CVS repositories.+'''Compiling the sources''' allows you to create executables from modified code. The instructions below show you how to compile the lastest code from the SVN repositories.
==Preparation== ==Preparation==
Line 6: Line 6:
The following software must be installed before starting. The following software must be installed before starting.
See [[Development Tools]] for download locations. See [[Development Tools]] for download locations.
-*.NET Framework SDK+*.NET Framework SDK 2.0 ([http://www.microsoft.com/downloads/details.aspx?familyid=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en NET Framework 2.0 Software Development Kit (SDK) (x86)])
-*DirectX SDK+:Note: If you have already installed Microsoft Visual Studio .NET 2005, you do not need to install the .NET Framework SDK separately. Visual Studio .NET 2005 includes the SDK.
-*A CVS client (e.g. TortoiseCVS or WinCVS)+*Managed DirectX ([http://www.microsoft.com/downloads/details.aspx?FamilyID=4B1F5D0C-5E44-4864-93CD-464EF59DA050&displaylang=en DirectX 9.0c Redistributable (February 2007)])
-*A .NET 'make' style utility (e.g. Visual Studio.NET or NAnt)+:Note: Above is the latest version. World Wind should compile with [http://www.microsoft.com/downloads/details.aspx?FamilyID=9930efa6-9f7b-4c8a-aea2-97dd6ab307a2&DisplayLang=en October 2005 version]
-Note: with VS.NET you will be loading the project(s) into a GUI and compiling, with Nant you will be compiling from the command line+*A SVN client (e.g. [http://tortoisesvn.tigris.org/ TortoiseSVN])
 +*Visual Studio 2005 (free Visual C# Express version available from [http://msdn.microsoft.com/vstudio/express/visualcsharp/default.aspx Microsoft])
===Get the Source Code=== ===Get the Source Code===
-See [[Source Code]] for more information.+See [[source code]] for more information.
-====Using TortoiseCVS====+====Using TortoiseSVN====
#Create a directory on your drive where you'd like to develop from (eg C:\wwdev) #Create a directory on your drive where you'd like to develop from (eg C:\wwdev)
-#Right-click in that directory and select "CVS Checkout"+#Right-click in that directory and select "SVN Checkout"
-##On the Module tab:+##Repository:
-###CVSROOT = :pserver:anonymous@cvs.sourceforge.net:/cvsroot/nasa-exp+###URL of repository = https://nasa-exp.svn.sourceforge.net/svnroot/nasa-exp/trunk/WorldWind
-###Server = cvs.sourceforge.net+##Revision: if you want to use anything other than SVN HEAD revision, you'll have to select "Revision" radio button, then click the "Show log" button, then select the revision from the list
-###Repository folder = /cvsroot/nasa-exp+
-###User name = anonymous+
-###Module = WorldWind+
-##On the Revision tab, if you want to use anything other than CVS HEAD, you'll have to select "Choose branch or tag", then click the "Update list" button, then select the branch/tag from the list+
-##On the Options tab, you may want to change "Name of folder to create" to use the tag/branch/revision in the folder name+
##Click OK, and the source code should be downloaded ##Click OK, and the source code should be downloaded
-##Click OK to close the TortoiseCVS window+##Click OK to close the TortoiseSVN window
- +
-====Using WinCVS====+
-#Create a directory on your drive where you'd like to develop from (eg C:\wwdev)+
-#Launch WinCVS+
-#Select your directory in the directory pane on the left side+
-#Right Click and choose "<code>Checkout Module...</code>"+
-#Type "<code>WorldWind</code>" in "Module Name and path on the server"+
-#Type "<code>:pserver;username=anonymous;hostname=cvs.sourceforge.net:/cvsroot/nasa-exp</code>" in "CVSROOT"+
-#Click OK. CVS Will now check out the source code for WorldWind in a "<code>WorldWind</code>" directory under your chosen one. (A window may come up asking for your default directory. Just click OK)+
-#Close WinCVS+
==Compile the Source Code== ==Compile the Source Code==
Line 43: Line 29:
===Compiling using Visual Studio=== ===Compiling using Visual Studio===
-====Compile within Studio====+====Compile within Visual C# Express====
-Replace C:\wwdev\WorldWind\ with your source directory:+Replace C:\wwdev\ with your source directory:
#Navigate to the following file and double click it: #Navigate to the following file and double click it:
-##C:\wwdev\WorldWind\WorldWindow.sln+##C:\wwdev\WorldWind\WorldWindow.csproj
-##If using MS VS 2005 it will ask to convert the file, NEXT->NEXT->FINISH+##or C:\wwdev\WorldWind.sln
-##From the Build menu, select Build WorldWindow, and in the Output window you should get a message that the build succeeded+#From the Build menu, select Build Solution, and in the Output window you should get a message that the build succeeded.
-##Close Visual Studio+#Close Visual Studio
-#Navigate to the following file and double click it:+:You may choose 'Debug' or 'Release' from the Build->Configuration Manager menu.
-##C:\wwdev\WorldWind\WorldWind.sln+=====Importing into Visual C# 2008 Express=====
-##If using MS VS 2005 it will ask to convert the file, NEXT->NEXT->FINISH+#Click ''File->Open Project''
-##From the Build menu, select Build WorldWindow, and in the Output window you should get a message that the build succeeded+#Navigate to the source directory
-##Close Visual Studio+#Choose ''WorldWind.sln'' and click ''Open''
 +#In the Conversion Wizard click ''Next''
 +##You can create a backup before converting the project.
 +#Click ''Next'' again, review the summary and click ''Finish''
 +##Here you can review coversion errors - just ignore them, WW should compile fine.
 +#Click ''Close''... Voilà! You can compile WW now. Make sure to choose 'Debug' or 'Release' from the Build->Configuration Manager menu as some of the other configurations will give errors.
====Compile from the commandline==== ====Compile from the commandline====
-# Launch the 'Visual Studio .NET 2003 Command Prompt' (under Start / Programs / Visual Studio .NET / Visual Studio .NET Tools)+# Launch the 'Visual Studio .NET 2005 Command Prompt' (under Start / Programs / Visual Studio .NET / Visual Studio .NET Tools)
# CD to the WorldWind source root. # CD to the WorldWind source root.
# Run 'Devenv.exe WorldWindow.sln /build Debug' # Run 'Devenv.exe WorldWindow.sln /build Debug'
# Run 'Devenv.exe WorldWind.sln /build Debug' # Run 'Devenv.exe WorldWind.sln /build Debug'
-* Replace 'Debug' with 'Release' as desired+:Replace 'Debug' with 'Release' as desired
-* As of 1.3.0 the references in the Release build point to /Debug dll's. So to /rebuild a release, /rebuild debug first.+:As of 1.3.0 the references in the Release build point to /Debug dll's. So to /rebuild a release, /rebuild debug first.
- +
-===Compiling using NAnt===+
-#Open a Command Prompt and cd to your work directory (<code>cd \wwdev\WorldWind</code>)+
-#<span>Type "<code>c:\nant-0.85-rc2\bin\nant</code>" (change the path to reflect where you installed Nant)<br>or "<code>c:\nant-0.85-rc2\bin\nant -buildfile:default.release.build</code>" for non-debug binaries</span>+
-If all goes well, you should get <tt>BUILD SUCCEEDED</tt> in the end+
==Data Setup== ==Data Setup==
Select one of the following options: Select one of the following options:
-#Use all new data - just proceed to the next section to run the compiled code+#Use a fresh copy of imagery and terrain data - just proceed to the next section to run the compiled code
-#If you already have a version of World Wind installed, and you already have files cached on your PC's harddisk that you want to make use of, then copy your existing Cache directory (e.g. C:\Program FIles\NASA\World Wind\Cache) to be a subdirectory of the directory containing your compiled source code's executable file (e.g. C:\wwdev\WorldWind\Cache)+#If you already have a version of World Wind installed, and you already have files on your PC's harddisk that you want to make use of:
-#If you already have a version of World Wind installed, and you already have files cached on your PC's harddisk that you want to make use of, then you can change your version of World Wind to point to that existing directory. Following the instructions above, open WorldWind.sln, then edit the App.Config file key "CacheDirectory" to point to your exisiting Cache directory, save the change, then compile WorldWind.+##Cache files - use either of the following:
 +###Copy your existing Cache directory (e.g. C:\Program FIles\NASA\World Wind\Cache) to be a subdirectory of the directory containing your compiled source code's executable file (e.g. C:\wwdev\bin\debug\Cache)
 +###If you already have a version of World Wind installed, and you already have files cached on your PC's harddisk that you want to make use of, then you can change your compiled version of World Wind to point to that existing directory. Run World Wind, press Alt+Q, then change the Cache path to point to your exisiting Cache directory, close the window, then restart World Wind.
==Run Your Compiled Code== ==Run Your Compiled Code==
-Your newly built WorldWind should now be ready to go. Double click on WorldWind.exe (e.g. C:\wwdev\WorldWind\WorldWind.exe) and it should start.+Your newly built World Wind should now be ready to go. Double click on WorldWind.exe (e.g. C:\wwdev\bin\Debug\WorldWind.exe) and it should start.
If you make changes to the source files that you would like to compile, just follow the [[#Compile the Code|Compile the Code]] instructions again to recompile, and after the compile, make sure to save the changes. If you make changes to the source files that you would like to compile, just follow the [[#Compile the Code|Compile the Code]] instructions again to recompile, and after the compile, make sure to save the changes.
 +
 +==See also==
 +*[[Latest builds]] to get already compiled builds
[[Category:Dev]] [[Category:Dev]]

Current revision

Compiling the sources allows you to create executables from modified code. The instructions below show you how to compile the lastest code from the SVN repositories.

Contents

[edit] Preparation

[edit] Install Software

The following software must be installed before starting. See Development Tools for download locations.

Note: If you have already installed Microsoft Visual Studio .NET 2005, you do not need to install the .NET Framework SDK separately. Visual Studio .NET 2005 includes the SDK.
Note: Above is the latest version. World Wind should compile with October 2005 version
  • A SVN client (e.g. TortoiseSVN)
  • Visual Studio 2005 (free Visual C# Express version available from Microsoft)

[edit] Get the Source Code

See source code for more information.

[edit] Using TortoiseSVN

  1. Create a directory on your drive where you'd like to develop from (eg C:\wwdev)
  2. Right-click in that directory and select "SVN Checkout"
    1. Repository:
      1. URL of repository = https://nasa-exp.svn.sourceforge.net/svnroot/nasa-exp/trunk/WorldWind
    2. Revision: if you want to use anything other than SVN HEAD revision, you'll have to select "Revision" radio button, then click the "Show log" button, then select the revision from the list
    3. Click OK, and the source code should be downloaded
    4. Click OK to close the TortoiseSVN window

[edit] Compile the Source Code

[edit] Compiling using Visual Studio

[edit] Compile within Visual C# Express

Replace C:\wwdev\ with your source directory:

  1. Navigate to the following file and double click it:
    1. C:\wwdev\WorldWind\WorldWindow.csproj
    2. or C:\wwdev\WorldWind.sln
  2. From the Build menu, select Build Solution, and in the Output window you should get a message that the build succeeded.
  3. Close Visual Studio
You may choose 'Debug' or 'Release' from the Build->Configuration Manager menu.
[edit] Importing into Visual C# 2008 Express
  1. Click File->Open Project
  2. Navigate to the source directory
  3. Choose WorldWind.sln and click Open
  4. In the Conversion Wizard click Next
    1. You can create a backup before converting the project.
  5. Click Next again, review the summary and click Finish
    1. Here you can review coversion errors - just ignore them, WW should compile fine.
  6. Click Close... Voilà! You can compile WW now. Make sure to choose 'Debug' or 'Release' from the Build->Configuration Manager menu as some of the other configurations will give errors.

[edit] Compile from the commandline

  1. Launch the 'Visual Studio .NET 2005 Command Prompt' (under Start / Programs / Visual Studio .NET / Visual Studio .NET Tools)
  2. CD to the WorldWind source root.
  3. Run 'Devenv.exe WorldWindow.sln /build Debug'
  4. Run 'Devenv.exe WorldWind.sln /build Debug'
Replace 'Debug' with 'Release' as desired
As of 1.3.0 the references in the Release build point to /Debug dll's. So to /rebuild a release, /rebuild debug first.

[edit] Data Setup

Select one of the following options:

  1. Use a fresh copy of imagery and terrain data - just proceed to the next section to run the compiled code
  2. If you already have a version of World Wind installed, and you already have files on your PC's harddisk that you want to make use of:
    1. Cache files - use either of the following:
      1. Copy your existing Cache directory (e.g. C:\Program FIles\NASA\World Wind\Cache) to be a subdirectory of the directory containing your compiled source code's executable file (e.g. C:\wwdev\bin\debug\Cache)
      2. If you already have a version of World Wind installed, and you already have files cached on your PC's harddisk that you want to make use of, then you can change your compiled version of World Wind to point to that existing directory. Run World Wind, press Alt+Q, then change the Cache path to point to your exisiting Cache directory, close the window, then restart World Wind.

[edit] Run Your Compiled Code

Your newly built World Wind should now be ready to go. Double click on WorldWind.exe (e.g. C:\wwdev\bin\Debug\WorldWind.exe) and it should start.

If you make changes to the source files that you would like to compile, just follow the Compile the Code instructions again to recompile, and after the compile, make sure to save the changes.

[edit] See also

Personal tools