Notes for 1.3.2 work

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 17:04, 7 April 2005 (edit)
Llynix (Talk | contribs)
m (Bugs to Squash)
← Previous diff
Revision as of 17:08, 7 April 2005 (edit) (undo)
Llynix (Talk | contribs)
m (Bugs to Squash)
Next diff →
Line 19: Line 19:
<b>Bugs noted in 1.3.1alpha4 with font patch (dpatton)</b> <b>Bugs noted in 1.3.1alpha4 with font patch (dpatton)</b>
-<ul>+ 
-<li>at program startup, the earth is partially covered by the+*at program startup, the earth is partially covered by the
toolbar at the top, even though there is free space below the toolbar at the top, even though there is free space below the
-earth at the bottom of the window(800x600 screen)</li>+earth at the bottom of the window(800x600 screen)
-<li>at program startup, Wireframe(CTRL+W) turns off the+*at program startup, Wireframe(CTRL+W) turns off the
toolbar grey background and draws a diagonal line across toolbar grey background and draws a diagonal line across
-the toolbar, and if it's open, the Layer Manager window</li>+the toolbar, and if it's open, the Layer Manager window (not a bug, wireframe is a feature on the card and all polygons are reduced to their parent triangles when it is tripped.) -- Llynix
-<li>at program startup, if both Blue Marble layers are turned+*at program startup, if both Blue Marble layers are turned
off, there is no Earth shown(probably "functions as designed"), off, there is no Earth shown(probably "functions as designed"),
-but then using Wireframe(CTRL+W) doesn't show a wireframe</li>+but then using Wireframe(CTRL+W) doesn't show a wireframe
-<li>World Settings(ALT+W) - at least some of the settings,+*World Settings(ALT+W) - at least some of the settings,
when changed, do not make the corresponding change in the when changed, do not make the corresponding change in the
UI until WW is stopped and restarted. For example, setting ShowPlacenames to False still leaves the Placenames layer UI until WW is stopped and restarted. For example, setting ShowPlacenames to False still leaves the Placenames layer
-(which is selected by default) on.</li>+(which is selected by default) on.
-<li>The "World Settings"(ALT+W) should be combined with the+*The "World Settings"(ALT+W) should be combined with the
-"World Wind Settings"(ALT+Q) into one interface. -- Tools->Settings</li>+"World Wind Settings"(ALT+Q) into one interface. -- Tools->Settings
-<li>Full Screen isn't working properly(WinXP). ALT+Enter+*Full Screen isn't working properly(WinXP). ALT+Enter
does go to fullscreen, but using ALT+Enter or ESC to revert does go to fullscreen, but using ALT+Enter or ESC to revert
from fullscreen doesn't show the Windows taskbar until you from fullscreen doesn't show the Windows taskbar until you
task switch to another program. "Full Screen" from the task switch to another program. "Full Screen" from the
View menu doesn't do real fullscreen - it leaves the View menu doesn't do real fullscreen - it leaves the
-Windows taskbar.</li>+Windows taskbar.
-<li>\Cache\Earth\TerrainAccesspr\SRTM and \SRTM30US subdirectories have+*\Cache\Earth\TerrainAccesspr\SRTM and \SRTM30US subdirectories have
both the .bil and .7z files</li> both the .bil and .7z files</li>
-<li>this URL: worldwind://goto/world=Earth&lat=48.00000&lon=-122.00000&alt=10000 when+*this URL: worldwind://goto/world=Earth&lat=48.00000&lon=-122.00000&alt=10000 when
used with 1.3beta took the user to 48N 122W at an altitude of used with 1.3beta took the user to 48N 122W at an altitude of
10,000 meters, but in 1.3.1 it ends up at 9,851 meters altitude. 10,000 meters, but in 1.3.1 it ends up at 9,851 meters altitude.
The SRTM terrain height at 48N 122W is 149 meters, so 1.3.1 is The SRTM terrain height at 48N 122W is 149 meters, so 1.3.1 is
calculating the camera altitude as the altitude requested in the calculating the camera altitude as the altitude requested in the
-URL(10,000m) less the terrain height(149m)</li>+URL(10,000m) less the terrain height(149m)
-<li>for various layers(both NLT and USGS) some image tiles are+*for various layers(both NLT and USGS) some image tiles are
-saved as .jpg and some as .dds</li>+saved as .jpg and some as .dds
-<li>using this location: worldwind://goto/world=Earth&lat=48.53976&lon=-122.47993&alt=796536 and+*using this location: worldwind://goto/world=Earth&lat=48.53976&lon=-122.47993&alt=796536 and
the NLT layer, even with "refresh view", there is a strip along the NLT layer, even with "refresh view", there is a strip along
the right-hand side of the viewport, on an 800x600 system, that the right-hand side of the viewport, on an 800x600 system, that
isn't covered by NLT tiles. Moving to the East just continues to leave a strip on the right-hand side. Looks like if the tile bounding box is isn't covered by NLT tiles. Moving to the East just continues to leave a strip on the right-hand side. Looks like if the tile bounding box is
partially off the right-hand side of the screen it won't try and partially off the right-hand side of the screen it won't try and
-download the tile.</li>+download the tile.
-</ul>+
==Current Functions to Improve== ==Current Functions to Improve==

Revision as of 17:08, 7 April 2005

Ok, lets have a better game plan for 1.3.2

We should feature freeze at least 2 weeks before the release to allow for bug fixing and installer building AND release testing.

Bugs need to be in Source Forge's bug list to be considered for fixing. -- Bugs definitely need to be collected 'somewhere'. That somewhere should be in one centralized place.


Contents

Features to Add

  • bookmarks menu!
  • for the keyboard zoom keys(1 and 7) add a modifier key(e.g. CTRL or ALT or SHIFT) to change zoom increment to 1 meter at a time, so the user can zoom easily to a specifc altitude(e.g. 10,000m) (dpatton)
  • for each layer, have a way to zoom to the appropriate altitude to use the maximum zoom level tiles, the minimum zoom level tiles, and each 'zoom step' for that layer in between (dpatton)

Bugs to Squash

Newest bugs on top

  • Some icons are no longer loaded into the tool bar: <Spacechicken_> fool: Add-on I created. Shows up in the tool bar in 1.3 - disappears in 1.3.1 (fool) Fix your spelling in your add-ons and all will be well (Llynix)
  • Gaps in trails, trails are not properly mapped to terrain at 0 elevation. (bull)
  • WW downloads terrian data when vert exag is zero (engmike)

Bugs noted in 1.3.1alpha4 with font patch (dpatton)

  • at program startup, the earth is partially covered by the

toolbar at the top, even though there is free space below the earth at the bottom of the window(800x600 screen)

  • at program startup, Wireframe(CTRL+W) turns off the

toolbar grey background and draws a diagonal line across the toolbar, and if it's open, the Layer Manager window (not a bug, wireframe is a feature on the card and all polygons are reduced to their parent triangles when it is tripped.) -- Llynix

  • at program startup, if both Blue Marble layers are turned

off, there is no Earth shown(probably "functions as designed"), but then using Wireframe(CTRL+W) doesn't show a wireframe

  • World Settings(ALT+W) - at least some of the settings,

when changed, do not make the corresponding change in the UI until WW is stopped and restarted. For example, setting ShowPlacenames to False still leaves the Placenames layer (which is selected by default) on.

  • The "World Settings"(ALT+W) should be combined with the

"World Wind Settings"(ALT+Q) into one interface. -- Tools->Settings

  • Full Screen isn't working properly(WinXP). ALT+Enter

does go to fullscreen, but using ALT+Enter or ESC to revert from fullscreen doesn't show the Windows taskbar until you task switch to another program. "Full Screen" from the View menu doesn't do real fullscreen - it leaves the Windows taskbar.

  • \Cache\Earth\TerrainAccesspr\SRTM and \SRTM30US subdirectories have

both the .bil and .7z files</li>

used with 1.3beta took the user to 48N 122W at an altitude of 10,000 meters, but in 1.3.1 it ends up at 9,851 meters altitude. The SRTM terrain height at 48N 122W is 149 meters, so 1.3.1 is calculating the camera altitude as the altitude requested in the URL(10,000m) less the terrain height(149m)

  • for various layers(both NLT and USGS) some image tiles are

saved as .jpg and some as .dds

the NLT layer, even with "refresh view", there is a strip along the right-hand side of the viewport, on an 800x600 system, that isn't covered by NLT tiles. Moving to the East just continues to leave a strip on the right-hand side. Looks like if the tile bounding box is partially off the right-hand side of the screen it won't try and download the tile.

Current Functions to Improve

  • Support for proxy autodiscovery, proxy scripts, proxy authentication (gillesk)
  • Re-Examine WMS, SVS and MODIS.. can use improvement (TomServo) (Will look that in more detail to get some specific notes)
    • Add support for WMS 1.0.0
  • have "Refresh Current View" default to both image tiles and terrain data, but have the option to refresh only tiles or only terrain data (dpatton)
  • keyboard navigation (fool)

Installer

Personal tools