Sky and Fog Plug-ins

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 03:45, 24 November 2005 (edit)
Nosilleg (Talk | contribs)
m ("plug-in", linked to userpage, linked Layer Manager)
← Previous diff
Current revision (23:24, 30 January 2009) (edit) (undo)
Patmurris (Talk | contribs)
(Updated for WW 1.4)
 
(12 intermediate revisions not shown.)
Line 4: Line 4:
caption = Mount St-Helens and Adams, WA, US | caption = Mount St-Helens and Adams, WA, US |
developer = [[User:Patmurris|Patrick Murris]] | developer = [[User:Patmurris|Patrick Murris]] |
- latest_release_version = 1.1 | + latest_release_version = 1.3 |
- latest_release_date = June 19th, 2005 |+ latest_release_date = November 6, 2006 |
license = public domain | license = public domain |
- website = [http://www.alpix.com/3d/worldwin/WW132_SkyAndFog11.zip Download] |+ website = [http://www.alpix.com/3d/worldwin/WW14_SkyAndFog_13.zip Download] |
}} }}
 +
== Summary == == Summary ==
This plug-in adds a sky dome and fog effect to World Wind. This plug-in adds a sky dome and fog effect to World Wind.
Line 21: Line 22:
Start WW and go to Plug-ins/Load-Unload. Load Sky and Fog plugins. For settings, right click on layers in the layer manager (L key). Start WW and go to Plug-ins/Load-Unload. Load Sky and Fog plugins. For settings, right click on layers in the layer manager (L key).
-Note : only works with WW 1.3.2 or above+Note : versions prior to 1.3 will only work with WW 1.3.2 or above. Also, World Wind 1.4 (but possibly already in 1.3.6 or even earlier) introduced a change that broke this plug-in. A fix has already been committed to the [[source code]] and will be available in a future 1.4.1 release. Use version 1.3 for WW 1.4.
== Links == == Links ==
-*[http://forum.worldwind.arc.nasa.gov/index.php?showtopic=3681&st=0 World Wind Forums Thread]+*[http://forum.worldwindcentral.com/showthread.php?t=6597 World Wind Forums Thread]
 +*[http://forum.worldwindcentral.com/showthread.php?t=9145 World Wind Forums Thread for the new fog plugin]
*[http://www.alpix.com/3d/worldwin/WW132_SkyAndFog11.zip Download plug-in v1.1] *[http://www.alpix.com/3d/worldwin/WW132_SkyAndFog11.zip Download plug-in v1.1]
 +*[http://www.alpix.com/3d/worldwin/WW14_SkyAndFog_13.zip Download plug-in v1.3 for WW 1.4]
Line 31: Line 34:
*[http://www.philohome.com/skycollec/skycollec.htm Philo's Free Hemisphical Sky Collection]. Use upper part of "equirectangular corrected images". *[http://www.philohome.com/skycollec/skycollec.htm Philo's Free Hemisphical Sky Collection]. Use upper part of "equirectangular corrected images".
 +==See also==
 +*[[Add-on:Stars3D|Stars3D plug-in]] A subset of the Hipparcos catalog as star background.
 +*[[Add-on:Atmospheric_halo|Atmospheric halo]] Original Mashi's plug-in revisited.
 +*[[Add-on:Global_Clouds|Global Clouds]] A cloud layer around the globe.
 +*[[Add-on:Globe_Icon|Globe icon plug-in]]. Adds a mini globe and overview window.
 +*[[Add-on:Compass_Rose|Compass rose plug-in]]. Adds a compass to World Wind.
-[[Category:Add-ons]]+[[Category:Plugins]]
 +[[Category:Plugins1.4]]

Current revision

Sky and Fog plug-ins
Mount St-Helens and Adams, WA, US
Mount St-Helens and Adams, WA, US
Developer Patrick Murris
Latest release 1.3 / November 6, 2006
License public domain
Web site Download

Contents

[edit] Summary

This plug-in adds a sky dome and fog effect to World Wind.

Sky and Fog appear as two layers in the Layer Manager. Right click on a layer for settings.

Choice of five fog thickness, two sky bitmaps and several gradiants. New bitmaps can be droped in the 'SkyAndFog' plug-in folder and become available in the settings - jpg or png. Settings are saved.

[edit] Install

Unzip the file in your 'Program Files/NASA/World Wind 1.3/Plugins' directory. That should create a new plug-in folder named SkyAndFog.

Start WW and go to Plug-ins/Load-Unload. Load Sky and Fog plugins. For settings, right click on layers in the layer manager (L key).

Note : versions prior to 1.3 will only work with WW 1.3.2 or above. Also, World Wind 1.4 (but possibly already in 1.3.6 or even earlier) introduced a change that broke this plug-in. A fix has already been committed to the source code and will be available in a future 1.4.1 release. Use version 1.3 for WW 1.4.

[edit] Links


You can find sky bitmaps here

[edit] See also

Personal tools