World Wind 1.3.1 Issues

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 23:25, 19 March 2005 (edit)
24.23.83.155 (Talk)
(Bugs)
← Previous diff
Current revision (14:48, 27 May 2008) (edit) (undo)
Mkpl (Talk | contribs)
m (Reverted edits by 80.229.24.24 (Talk); changed back to last version by Mkpl)
 
(62 intermediate revisions not shown.)
Line 1: Line 1:
-Target release date: Monday, March 21. Feature/high-risk commit freeze until then.+Target release date: sometime near the end of March. Feature/high-risk commit freeze until then.
 + 
 +==Bugs with 1.3.1 alpha3 Patch==
 +* Typeface in Layer Manager should be smaller
 +* L in Layer Manager tooltip is still cut off
 +* Bullets are still slightly elevated and off-center
 +* view - layermanager isnt synched with toolbar layermanager, if you close it with the x the view one remains ticked
 + 
 +==Bugs with Chris' Checkin==
 +* edit - refesh current view only re-downloads the data when you select it the second time. (Bug or feature?)
==Bugs== ==Bugs==
-* Font problem: Wingdings2/3 is MS Office-only and many don't have it. Randy has made a new font which needs to be installed in the installer. shockfire says: I have PCs where i can't install fonts, so I'd like some workaround for this 
-* Jessi needs to check installer changes into CVS 
-* Placenames bug: If you turn placenames off, and back on again, they don't come back. A restart is needed then to get the placenames back. (anyone interested in fixing this?) 
* New keychart (local file) needs to be distributed. * New keychart (local file) needs to be distributed.
-* Shock will fix DDS/JPG saving bug 
-* Shock/Mashi will fix download indicator polish issues: [[DownloadIndicatorProposal]] 
-* Chris will enable tile expiry; is there a way to enable expiry for certain datasets (eg NLT) and not others? 
-* gillesk's installer polish issues: 
- 
- 12:43 < gillesk> this is from installing 1.3 on a few machines, minor stuff: 
- 12:43 < gillesk> - encoding with the foreign languages seems wrong 
- 12:44 < gillesk> - after installing managed DirectX, the installer hides in the background - some users do not find it in their (hidden) taskbar ... 
- 12:51 < dpatton_[CA]> jessi-nlt: not a bug, but the release should in clude a "list of changes", both for program changes(e.g. fixes and enhancemnets) and for data changes(e.g. new NLT server coverage, reprocessed colors, etc.) 
 +==Fixed, should be tested==
 +* DDS/JPG saving bug (Only save DDS when xml tag is set to DDS, only save (and load) JPG when it's set to JPG) -- '''DOESN'T''' seem to work in 1.3.1A4 yet (28-03-05, 22:00GMT). [http://worldwind.arc.nasa.gov/forums/index.php?showtopic=2025 (See post on forum)]
 +* Tile download problems apparently fixed.
 +* Mashi has made it so Tahoma happens first, then default system font. ((Tahoma changed to Arial (since Tahoma isn't a "standard" Windows font). Some people feel Arial is harder to read. '''Note:''' (Tahoma '''is''' a standard Windows font in 98/2000/XP - [http://www.autoitscript.com/autoit3/docs/appendix/fonts.htm Standard Windows Fonts] -adamhill)))
 +* Placenames seem to all be bold; least important things (small towns) shouldn't be bold, although continents/countries should (Chris fixed)
 +* Jessi needs to check installer changes into CVS
 +* <ShockFire> bug: starting with /f doesn't work right (fixed itself)
 +* infomation typo in xml fixed; add-on authors need to update XML files
 +* Placenames bug: If you turn placenames off, and back on again, they don't come back. A restart is needed then to get the placenames back. (anyone interested in fixing this?)
* WW_Automation.xsd needs to be fixed in HEAD, included in instal1: * WW_Automation.xsd needs to be fixed in HEAD, included in instal1:
Line 25: Line 31:
(the only reason I havent already comitted it is that I dont know if this .xsd file is part of an autogenerated set and will just get over written. -ah) (the only reason I havent already comitted it is that I dont know if this .xsd file is part of an autogenerated set and will just get over written. -ah)
-==Fixed, should be tested==+==1.3.2==
-* Tile download problems apparently fixed.+* Download indicator polish issues: [[DownloadIndicatorProposal]]
-* Mashi has made it so Tahoma happens first, then default system font. ((Tahoma changed to Arial (since Tahoma isn't a "standard" Windows font). Some people feel Arial is harder to read. '''Note:''' (Tahoma '''is''' a standard Windows font in 98/2000/XP - [http://www.autoitscript.com/autoit3/docs/appendix/fonts.htm Standard Windows Fonts] -adamhill)))+ 
 +[[Category:Deprecated Pages]]

Current revision

Target release date: sometime near the end of March. Feature/high-risk commit freeze until then.

Contents

[edit] Bugs with 1.3.1 alpha3 Patch

  • Typeface in Layer Manager should be smaller
  • L in Layer Manager tooltip is still cut off
  • Bullets are still slightly elevated and off-center
  • view - layermanager isnt synched with toolbar layermanager, if you close it with the x the view one remains ticked

[edit] Bugs with Chris' Checkin

  • edit - refesh current view only re-downloads the data when you select it the second time. (Bug or feature?)

[edit] Bugs

  • New keychart (local file) needs to be distributed.

[edit] Fixed, should be tested

  • DDS/JPG saving bug (Only save DDS when xml tag is set to DDS, only save (and load) JPG when it's set to JPG) -- DOESN'T seem to work in 1.3.1A4 yet (28-03-05, 22:00GMT). (See post on forum)
  • Tile download problems apparently fixed.
  • Mashi has made it so Tahoma happens first, then default system font. ((Tahoma changed to Arial (since Tahoma isn't a "standard" Windows font). Some people feel Arial is harder to read. Note: (Tahoma is a standard Windows font in 98/2000/XP - Standard Windows Fonts -adamhill)))
  • Placenames seem to all be bold; least important things (small towns) shouldn't be bold, although continents/countries should (Chris fixed)
  • Jessi needs to check installer changes into CVS
  • <ShockFire> bug: starting with /f doesn't work right (fixed itself)
  • infomation typo in xml fixed; add-on authors need to update XML files
  • Placenames bug: If you turn placenames off, and back on again, they don't come back. A restart is needed then to get the placenames back. (anyone interested in fixing this?)
  • WW_Automation.xsd needs to be fixed in HEAD, included in instal1:
12:36 < Bull_[UK]> the new scripting update has a bug
12:37 < adamhill> line 279
12:37 < adamhill> in WW_Automation.xsd
12:37 < Bull_[UK]> <_adam_gfx> Bull: change the second 'X' on line 279 to a 'Y'

(the only reason I havent already comitted it is that I dont know if this .xsd file is part of an autogenerated set and will just get over written. -ah)

[edit] 1.3.2

Personal tools