World Wind 1.3.6 - 1.4 Bug List For Release

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 19:26, 17 December 2006 (edit)
Withak (Talk | contribs)
(1.4 Bugs)
← Previous diff
Current revision (18:15, 22 April 2007) (edit) (undo)
67.189.220.119 (Talk)
(Fixed)
 
(3 intermediate revisions not shown.)
Line 37: Line 37:
* HTTP 404 handling broken on tiles downloads, higher level tiles will be requested even if parent returned 404 (ie. L=0,X=0,Y=0 returns 404, L=1,X=0,Y=0 will still be tried and return more 404s). If this is a 'feature' please provide other means of informing downloader that higher level tiles doesnt exist (custom HTTP error code, custom header, ...). * HTTP 404 handling broken on tiles downloads, higher level tiles will be requested even if parent returned 404 (ie. L=0,X=0,Y=0 returns 404, L=1,X=0,Y=0 will still be tried and return more 404s). If this is a 'feature' please provide other means of informing downloader that higher level tiles doesnt exist (custom HTTP error code, custom header, ...).
* Need to change PlatformTarget from AnyCPU to x86 for future builds (fixes x86_64 issues) * Need to change PlatformTarget from AnyCPU to x86 for future builds (fixes x86_64 issues)
-* Weird issues with OnMars layer, including blurry islands and [http://issues.worldwind.arc.nasa.gov/browse/WW-638 WW-638]+* <s>Weird issues with OnMars layer, including blurry islands and [http://issues.worldwind.arc.nasa.gov/browse/WW-638 WW-638]</s> (blurry islands bug again)
* Links with target="_blank" attribute open new IE window * Links with target="_blank" attribute open new IE window
-* [http://issues.worldwind.arc.nasa.gov/browse/WW-649 WW-649] Sun shading - Sun position is correct only for the Earth+* <s>[http://issues.worldwind.arc.nasa.gov/browse/WW-649 WW-649] Sun shading - Sun position is correct only for the Earth</s> (New feature, not for 1.4)
-* If compass is on behind the Layer Manager you end up clicking the compass instead of the Layer Manager+* <s>If compass is on behind the Layer Manager you end up clicking the compass instead of the Layer Manager</s> (duplicate)
* NRL Weather plug-in still has broken links Here's a fixed version of the xml file, the images might not all be in the right spot, but the majority of them should be. [http://members.cox.net/packerbackerbro/NRL_Monterey.xml NRL_Monterey.xml] * NRL Weather plug-in still has broken links Here's a fixed version of the xml file, the images might not all be in the right spot, but the majority of them should be. [http://members.cox.net/packerbackerbro/NRL_Monterey.xml NRL_Monterey.xml]
* <s>On the KML importer, the extrude line should not be drawn if the linestyle width parameter is set to 0. I use this to destinguish between the current track and history tracks when plotting aircraft positions. This is in JIRA here [http://issues.worldwind.arc.nasa.gov/browse/WW-624 WW-624]. Please see the screenshot I've posted in the forum [http://forum.worldwindcentral.com/showthread.php?p=37242#post37242 here]. Here are what my style tags looks like: * <s>On the KML importer, the extrude line should not be drawn if the linestyle width parameter is set to 0. I use this to destinguish between the current track and history tracks when plotting aircraft positions. This is in JIRA here [http://issues.worldwind.arc.nasa.gov/browse/WW-624 WW-624]. Please see the screenshot I've posted in the forum [http://forum.worldwindcentral.com/showthread.php?p=37242#post37242 here]. Here are what my style tags looks like:
Line 122: Line 122:
==== Minor bugs ==== ==== Minor bugs ====
 +* <ServerLogoFilePath> tag doesn't work - there is no logo above the progress bar
* Compass 3D and scale bar position and size and not saved across sessions (This would be better fixed by making all FormWidgets automatically remember their positions -- probably not for 1.4 though. I did make it so the time controller starts out in a better location. ~withak) * Compass 3D and scale bar position and size and not saved across sessions (This would be better fixed by making all FormWidgets automatically remember their positions -- probably not for 1.4 though. I did make it so the time controller starts out in a better location. ~withak)
* Timecontroller doesn't scale (as nicely as Compass 3D) (This is probably because the compass is a FormWidget holding a vector drawing and thus very easy to scale like that. The time controller is a FormWidget holding a bunch of raster button widgets. I think the "stretchy" behavior of the compass is a special case in this situation. ~withak) * Timecontroller doesn't scale (as nicely as Compass 3D) (This is probably because the compass is a FormWidget holding a vector drawing and thus very easy to scale like that. The time controller is a FormWidget holding a bunch of raster button widgets. I think the "stretchy" behavior of the compass is a special case in this situation. ~withak)
Line 133: Line 134:
* <s>Terrain looks "blocky" when sun shading is activated. The transitions between the tiles aren't seamless</s>. * <s>Terrain looks "blocky" when sun shading is activated. The transitions between the tiles aren't seamless</s>.
* <s>Help->About World Wind - the image doesn't fit</s> * <s>Help->About World Wind - the image doesn't fit</s>
-* <s>Compass doesn't have an icon to turn it on as in previous versions</s> 
-* <s>Help->Walktrough points to old site (alteviltech.com)</s> WW-647 fixed in SVN 
-* <s>NRL Weather plug-in still has broken links</s> 
-* <s>Clicking icons on the toolbar (Layer Manager, Lat/Lon lines) doesn't change the View menu</s> 
-* <s>Compass 3D and scale bar show a light rectangle overlay (should be transparent)</s> ''(color can be set in alt-w menu now)'' 
-* <s>Sun shading and atmospheric scattering : it would make sens to have options in the View menu - not only in the less accessible Options dialog</s> 
===Installer Bugs=== ===Installer Bugs===
* Installer does not exist at this point. * Installer does not exist at this point.

Current revision

This page is for listing of bugs that need to be squashed before there is a 1.3.6 and 1.4 release. This is the official bug list page. Be sure bugs are linked to a JIRA issue as well (if there is one). There will be no new features added, this is for bug squashing only.

World Wind 1.4 requires .NET 2.0 while World Wind 1.3.6 requires .NET 1.1 and is intended for users in corporate or educational IT environments who aren't able to update to .NET 2.0. If you maintain your own PC then install .NET 2.0 and use World Wind 1.4. World Wind 1.3.6 should eventually be identical to 1.4 with the exception of any new features that might require .NET 2.0.

Contents

[edit] Downloads

Please link to this page instead of direct download so bugs can be reported. Thanks.

[edit] 1.4 Download

To download and install the latest 1.4 beta version (RC1) follow these steps:

  1. Download the World_Wind_1.4_r3411.zip file
  2. Unzip the archive wherever you want. The best location is probably \Program Files\NASA\, it will create a separate folder from your existing WW 1.3 install.

You should be able to have 1.4 and 1.3 installed at the same time because they keep their settings in separate locations. If you have run any other builds of 1.4 then you should delete your %appdata%\NASA\World Wind\1.4.0.0\ folder.

NOTE: World Wind 1.4 requires .NET 2.0.

Related forum post

[edit] 1.3.6 Download

[edit] Bugs

Please read the list of fixed bugs before you add a new one

[edit] 1.3.6 Bugs

Most of the things broken in 1.4 are broken in 1.3.6 too

[edit] 1.4 Bugs

  • <CacheExpirationTime> tag for QTS doesn't work
  • World Wind fails to start on Windows Vista (build 6000)
  • F10 info display altitude above target instead of above sea level
  • "Blurry Island" bug is affecting ZoomIt! layers (See JIRA WW-687)
  • worldwind:// links with "world=" parameters don't switch worlds.
  • Waving flag textures don't appear with low-end graphics cards. Flags are just white squares.
  • Mouse clicks go thru windows like time controller
  • Placenames downloads freeze other downloads, queued requests arent removed when layer is disabled
  • Camera jitter on high zoom (ie. 100 meters)
  • HTTP 404 handling broken on tiles downloads, higher level tiles will be requested even if parent returned 404 (ie. L=0,X=0,Y=0 returns 404, L=1,X=0,Y=0 will still be tried and return more 404s). If this is a 'feature' please provide other means of informing downloader that higher level tiles doesnt exist (custom HTTP error code, custom header, ...).
  • Need to change PlatformTarget from AnyCPU to x86 for future builds (fixes x86_64 issues)
  • Weird issues with OnMars layer, including blurry islands and WW-638 (blurry islands bug again)
  • Links with target="_blank" attribute open new IE window
  • WW-649 Sun shading - Sun position is correct only for the Earth (New feature, not for 1.4)
  • If compass is on behind the Layer Manager you end up clicking the compass instead of the Layer Manager (duplicate)
  • NRL Weather plug-in still has broken links Here's a fixed version of the xml file, the images might not all be in the right spot, but the majority of them should be. NRL_Monterey.xml
  • On the KML importer, the extrude line should not be drawn if the linestyle width parameter is set to 0. I use this to destinguish between the current track and history tracks when plotting aircraft positions. This is in JIRA here WW-624. Please see the screenshot I've posted in the forum here. Here are what my style tags looks like:
 <Style id="track_history">
   <IconStyle>
     <scale>0.3</scale>
     <Icon>
       <href>images/track_history.png</href>
     </Icon>
   </IconStyle>
   <LineStyle>
     <color>73ffffff</color>
     <width>0.0</width>
   </LineStyle>
   <LabelStyle>
     <scale>0.0</scale>
   </LabelStyle>
 </Style>
 <Style id="track_current">
   <IconStyle>
     <color>ff00ffff</color>
     <scale>0.7</scale>
     <Icon>
       <href>images/track_current.png</href>
     </Icon>
   </IconStyle>
   <LineStyle>
     <color>73ffffff</color>
     <width>1.5</width>
   </LineStyle>
   <LabelStyle>
     <scale>0.57</scale>
   </LabelStyle>
 </Style> (I think kml importer doesn't support style tags yet.)

  • Legends (ScreenOverlay) turn themselves off when toggling layers on and off.
  • When sun shading is enabled lat&lon grid and measure tool lines are rendered in black
  • linefeatures are always extruded to ground. (even with <ExtrudeHeight> option explicitly set to 0).
  • When importing KML placemarks, the placemark discription no longer appears in the lower left hand corner of the screen when I mouse over the placemark icon. See this issue in JIRA WW-686. (Placemark descriptions are supposed to appear in html bubbles, whoever created the bubbles needs to fix them.)
  • Overlapping ESRI shapefiles cause massive distortions. When the shape is rendered, a larger rectangular area surrounding the shape is tinted slightly darker. These overlapping tinted regions combine to blot out the whole screen. This did not occur in V1.3.5. This is in JIRA here WW-690. I've also now added screen shots and sample ESRI shape files to the discussion here
  • Placemark Icons, such as those in the US Dams add-on, appear to move around on the ground if you pivot around them from a tilted perspective. This was a problem in V1.3.3.1, and was fixed in V1.3.5, but now appears to be back in the new Beta. This has been entered as an issue in JIRA here WW-691.

[edit] Fixed

  • On the KML Importer, placemarks don't show up if the altitude is not included. If it is not included then the alt should be assumed to be 0. The KML 2.1 standard indicates the altitude is optional. I've entered this issue in JIRA here WW-675. My bad. The parser I was using was leaving an extra comma in the coordinates. Although GE still opened it, I don't think it is valid KML.
 <coordinates>-80.7613,40.6314,</coordinates>  //Works in GE, not in WW 
 <coordinates>-80.7613,40.6314,0</coordinates>  //Works in both...
  • When the Sun Shading is on the latitude and longitude lines are turned gray.
  • Global placefinder does not work
  • WW-648 Should be a time resetbutton
  • Turning off Blue Marble layer changes other layers to white
  • When having the camera next to the ground, and targeting at the horizon, the sky disappears, and a black globe appears
  • Multithreaded downloading bugged, probably lacks proper locking, threads are downloading same file This is not correctly implemented in 1.4 an improved version is in development, removed option from alt+w
  • Links from icons in World Wind don't open up in the web browser
  • Menu: Plugins / Blue Marble / Month selector for BMNG doesn't allow to select months older than current one.
  • Timecontroller doesnt show current time
  • Sun shading - Does not work properly for Jupiter (shadows everywhere - day side seems to pop out sometime...)
  • TextureFormat is locked to DXT3, cant change to anything else
  • Waving flags didn't appear have to wait a bit
  • WW-642 - ZIP SRTM ISSUES causes spiky terrain (has anyone actually seen this with the current build?) (provisionally crossed-off until someone can confirm that it exists)
  • ZoomIt! url needs to be changed to http://worldwindxml.worldwindcentral.com/zoomit.xml or preferably http://worldwindxml.worldwindcentral.com/zoomit.xml?version=1.4.0.0
  • WW-630 - image overlay needs precision fix fix
  • Web browser:
    • entering p, l, v, b into the address field enables/disables WW functions - layer manager, WMS browser...)
    • after changing orientation V<->H (and resizing WW window) the browser might be hidden
  • WW-650 Atmospheric scattering is enabled for all planets. Fix in World.cs, line 408 : if (IsEarth && World.Settings.EnableAtmosphericScattering)
  • All the worlds have a blue atmosphere, just like the Earth.
  • Time controller and Sun shading is still on for the SDSS world if it was on for another, is it possible to disable those features since they aren't needed for SDSS
  • WW-651 Stars show over atmospheric scattering and the Sun (use additive alpha blending). Fix in World.cs : move line 426 RenderStars(drawArgs, RenderableObjects); before 408 if(World.Settings.EnableAtmosphericScattering)
  • Planetary Rings are off - need recenter fix
  • Should be able to choose if icon descriptions are shown (new feature, not a bug)
  • Some functions (eg. ModelFeatures !) won't work for french users (at least), due to parsing errors : should add CultureInfo.InvariantCulture to parsing instructions in...
    • PluginSDK/ConfigurationLoader.cs, ll. 2010-2021 : in Convert.ToSingle instructions (should be the same for commented addWater function a few lines below)
    • WorldWind/NRLWeather.cs, ll. 237-240 : in Double.Parse instructions
    • WorldWind/ShapeFileLoader.cs, ll. 857 and 889 : in Float.Parse instructions
      • Fixed these and many other CultureInfo bugs found by FxCop, updated files are here, should just have to unzip into source tree. There probably still more to fix, is there an automated way to do that?
    • Plugin PlanetaryRings.cs, ll 162-163 : Double.Parse Get fixed .cs here (v1.1)
  • Amount of information logged to WorldWind.log should be reduced (the logs are huge now because it was built in debug mode, a release build will cut down the amount of logging)
  • WMS Browser: couldn't connect to GLOBE server (System FormatException: Input String was not in a correct format) Server side error again.
  • Stars move in the wrong direction (from West to East). Fix in Stars3D.cs, line 189 : -2 * Math.PI
  • Splash screen does not show loading status messages (AFAIR it is supposed to work this way) - and seems to flicker ?

[edit] Minor bugs

  • <ServerLogoFilePath> tag doesn't work - there is no logo above the progress bar
  • Compass 3D and scale bar position and size and not saved across sessions (This would be better fixed by making all FormWidgets automatically remember their positions -- probably not for 1.4 though. I did make it so the time controller starts out in a better location. ~withak)
  • Timecontroller doesn't scale (as nicely as Compass 3D) (This is probably because the compass is a FormWidget holding a vector drawing and thus very easy to scale like that. The time controller is a FormWidget holding a bunch of raster button widgets. I think the "stretchy" behavior of the compass is a special case in this situation. ~withak)
  • Compass 3D only shrinks against bottom and right-hand side borders. (timecontroller doesn't do this at all) It also changes its position when title bar is visible (on mouse over)
  • SDSS @Images.xml needs to be changed, the WMAP doesn't have 21 levels it has 5. Zooming in past the fifth level gives you black tiles. Also can the icon images it references be in the Data directory rather than Addons since SDSS is included with World Wind?
  • Shall we remove duplicated add-ons/plugins? (i.e. Flags of the World/Waving Flags, Atmosphere plugin/Atmospheric scattering)
  • ScreenOverlays for icons are not visible (they work in 1.3.6) - WW-700
  • Network XML requests contain BBOX param (ie. .../index-1.3.4.xml?BBOX=-177.3730309438,-95.980852772773,2.6269690562001,84.019147227227)
[edit] Fixed
  • "Downloading Remote Image..." message needs reference center fix
  • Terrain looks "blocky" when sun shading is activated. The transitions between the tiles aren't seamless.
  • Help->About World Wind - the image doesn't fit

[edit] Installer Bugs

  • Installer does not exist at this point.
Personal tools