World Wind 1.4 Bug List For Release

From World Wind Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 15:20, 4 January 2007 (edit)
Withak (Talk | contribs)
(Fixed)
← Previous diff
Revision as of 15:21, 4 January 2007 (edit) (undo)
Withak (Talk | contribs)
(Fixed)
Next diff →
Line 50: Line 50:
* <s>Boundaries are too thick, and often show several different sizes/thicknesses in the same screen. Boundaries should not appear on coastlines (in 1.3.5 they did not, except for the US).</s> (not a WW bug)(if not a WW bug why does 1.3.5 do it differently and better?) * <s>Boundaries are too thick, and often show several different sizes/thicknesses in the same screen. Boundaries should not appear on coastlines (in 1.3.5 they did not, except for the US).</s> (not a WW bug)(if not a WW bug why does 1.3.5 do it differently and better?)
** In 1.3.5 boundaries were installed with WW (as vectors) and stored on your PC. That was part of the reason the installer was so large. In 1.4 they are downloaded from a NASA server (as rasters) as they are needed. This lets them be updated whenever necessary. Styling changes would need to be made by the admin of that server, not by the WW application. PS: 1.4 does it better IMO. :) ** In 1.3.5 boundaries were installed with WW (as vectors) and stored on your PC. That was part of the reason the installer was so large. In 1.4 they are downloaded from a NASA server (as rasters) as they are needed. This lets them be updated whenever necessary. Styling changes would need to be made by the admin of that server, not by the WW application. PS: 1.4 does it better IMO. :)
 +** The code to render 1.3.5-style boundaries is still in WW, so you could theoretically save the xml and boundary files from 1.3.5 and use them in 1.4 if you wanted to.
* <s>Compass shows ? instead of degree symbol ''(is it really fixed? i still see '?')'' </s> Fixed in SVN, this build isn't quite the latest. * <s>Compass shows ? instead of degree symbol ''(is it really fixed? i still see '?')'' </s> Fixed in SVN, this build isn't quite the latest.
* <s>FOTW shows Serbia and Montenegro as the same country.</s> * <s>FOTW shows Serbia and Montenegro as the same country.</s>

Revision as of 15:21, 4 January 2007

This release was made by FEF and is not endorsed or supported by NASA

This page is for listing of bugs that need to be squashed before there is a 1.4 release. This is the official bug list page. Be sure bugs are linked to a JIRA issue as well (if there is one). There will be no new features added, this is for bug squashing only.

World Wind 1.4 requires .NET 2.0

Contents

Downloads

Please link to this page instead of direct download so bugs can be reported. Thanks.

World Wind 1.4.0 RC2 (23 Dec 2006)

To download and install the latest 1.4 beta version (RC2) follow these steps:

  1. Download the World_Wind_1.4.0_RC2 installer
  2. Double click World_Wind_1.4.0_RC2.exe
  3. Pray

You should be able to have 1.4 and 1.3 installed at the same time because they keep their settings in separate locations. If you have run any other builds of 1.4 then you should delete your %appdata%\NASA\World Wind\1.4.0.0\ folder.

Please note the installer does not correctly detect your current version of DirectX, you will need to install DirectX December 2006 or World Wind 1.4 will not run.

NOTE: World Wind 1.4 requires .NET 2.0 and Managed DirectX December 2006.

Related forum post

Bugs

Please read the list of fixed bugs before you add a new one

1.4 Bugs

  • Worldwind.log is too verbose, also it validates against the xsd which is outdated
  • "System.NullReferenceException: Object reference not set to an instance of an object" errors after setting "Don't use proxy" in Conf. Wizard (anyone confirms?)
  • <CacheExpirationTime> tag for QTS doesn't work
  • "Blurry Island" bug is affecting ZoomIt! layers (See JIRA WW-687)
  • worldwind:// links with "world=" parameters don't switch worlds.
  • Waving flag textures don't appear with low-end graphics cards. Flags are just white squares.
  • Placenames downloads freeze other downloads, queued requests arent removed when layer is disabled
  • HTTP 404 handling broken on tiles downloads, higher level tiles will be requested even if parent returned 404 (ie. L=0,X=0,Y=0 returns 404, L=1,X=0,Y=0 will still be tried and return more 404s). If this is a 'feature' please provide other means of informing downloader that higher level tiles doesnt exist (custom HTTP error code, custom header, ...).
  • The description portion of KML Icons still don't pop up in a bubble, or anywhere else that I can tell. When importing KML placemarks, the placemark discription no longer appears in the lower left hand corner of the screen when I mouse over the placemark icon. See this issue in JIRA WW-686 (http://issues.worldwind.arc.nasa.gov/browse/WW-686). (Placemark descriptions are supposed to appear in html bubbles, whoever created the bubbles needs to fix them.) The code for displaying the description is still in the KMLImporter.CS but is commented out. I restored it, and it works just fine. Would someone be kind enough to un-comment the description code and check it back in?
  • Overlapping ESRI shapefiles cause massive distortions. When the shape is rendered, a larger rectangular area surrounding the shape is tinted slightly darker. These overlapping tinted regions combine to blot out the whole screen. This did not occur in V1.3.5. This is in JIRA here WW-690 (http://issues.worldwind.arc.nasa.gov/browse/WW-690). I've also now added screen shots and sample ESRI shape files to the discussion here (http://forum.worldwindcentral.com/showthread.php?p=38438#post38438)
  • The option for simultaneous tiles downloading has dissapeared from the options menu. (it was removed because it was broken -withak)

Fixed

  • Globalization issue in VE ("Input string was not in a correct format" during searching), Yahoo and TerraPage (error when clicking on the result list) geocoders
  • InfoUris for layers don't open in the integrated browser
  • Widgets don't use font from WW dir (close button is seen as 'F')
  • NRLMonterey has ,/. issue
  • VE plugin has zbuffer issues (see through terrain)
  • When I turn the Browser on, with the orientation with it on the left, and I turn on the Tool Bar, it does not come on.
  • The internal browser should remember settings as far as window size from the previous session with the same orientation. Whenever I start up WW and turn on the browser in Vertical Orientation, the browser takes up 1/3 of the screen. I then have to adjust the size to about 1/5 of the screen. It would be nice if the browser remembered this and started back up with the same window size. There is a mysterious issue with the size of the browser not being remembered and starting out very large. I can't find out why the size isn't being remembered correctly, but I made the initial size more reasonable. -withak
  • The 3D Compass should remember its size and location from session to session. I like to make it smaller, and put it in the upper right hand corner. I have to do this every time I start WW. Widgets remembering their positions would be a new feature, not a bug.
  • Screen Overlays with internet links don't open in the integrated web browser.
  • Boundaries are too thick, and often show several different sizes/thicknesses in the same screen. Boundaries should not appear on coastlines (in 1.3.5 they did not, except for the US). (not a WW bug)(if not a WW bug why does 1.3.5 do it differently and better?)
    • In 1.3.5 boundaries were installed with WW (as vectors) and stored on your PC. That was part of the reason the installer was so large. In 1.4 they are downloaded from a NASA server (as rasters) as they are needed. This lets them be updated whenever necessary. Styling changes would need to be made by the admin of that server, not by the WW application. PS: 1.4 does it better IMO. :)
    • The code to render 1.3.5-style boundaries is still in WW, so you could theoretically save the xml and boundary files from 1.3.5 and use them in 1.4 if you wanted to.
  • Compass shows ? instead of degree symbol (is it really fixed? i still see '?') Fixed in SVN, this build isn't quite the latest.
  • FOTW shows Serbia and Montenegro as the same country.

Minor bugs

Fixed

Other complaints ;)

  • Use BMNG+Bathymetry instead of plain BMNG
  • replace old atmospheric halo plugin with sky gradient (fix z-buffer issue first)
  • clicking links should open the integrated browser (if it's not visible) [but i guess it would be a new feature :P] (did that, and added a close button -withak)
  • Good New Year's advice 2007-01-01:
23:20:29 < withak> probably would have to default everything to off then, otherwise people will [complain] that it is slow (fixed, and added a page to config wizard pointing out that these features are off at startup -withak)
  • elevation of terrain under mouse not available (this would be new feature, not a bug)
  • In the PlaceFinder dialog, the Virtual Earth geocoder tab's textbox should say "Keywords or address" so that it is clear that the user can type in addresses as well as keywords. WW-707

Installer Bugs

  • Installer does not correctly detect your current version of DirectX.
  • uninstaller hangs on WINDOWS\Fonts\World Wind Dings 1.04.ttf (can anyone confirm this?) (the freeze could have been caused by Kerio firewall; but since WW uses font from its own directory the uninstaller shouldn't touch Windows\Fonts dir at all...)
  • The uninstaller should notify the user that the cache directory (potentially a large amount of disk space) was not deleted during the uninstall
Personal tools